3 Replies Latest reply: Aug 2, 2011 7:11 PM by GRAHAMSWIFT RSS

Enabled/Disabled virtual interface?

bmccullough
Currently Being Moderated

I have two FAS3140 running NetApp Release 7.3.1.1.  I am able to ping the IP addres of the first FAS but not the second FAS.  The second FAS is reporting they virtual interface as disabled!?!

 

I can ping out of the second FAS to other devices but not the reverse.

 

Help and thanks.

 

fas03> cf status
Cluster enabled, fas04 is up.

 

fas04> cf status
Cluster enabled, fas03 is up.

 

cat /mnt/fas03/etc/rc
hostname fas03
vif create lacp lvif1 -b ip e0a e0b e4a
vif create lacp lvif2 -b ip e4b e4c e4d
vif create single svif lvif1 lvif2
vlan create svif 340 348 351
ifconfig svif-340 `hostname`-svif-340 netmask 255.255.255.0 partner svif-340
ifconfig svif-348 `hostname`-svif-348 netmask 255.255.255.128 partner svif-348
ifconfig svif-351 `hostname`-svif-351 netmask 255.255.255.128 partner svif-351
ifconfig e0M `hostname`-e0M flowcontrol full netmask 255.255.255.0 partner e0M
route add default 10.13.240.1 1
route add net 10.13.244/24 10.13.244.1 1
routed on
options dns.enable off
options nis.enable off
savecore

 

fas03> ifconfig svif-340
svif-340: flags=948043<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500
        inet 10.13.240.23 netmask 0xffffff00 broadcast 10.13.240.255
        partner svif-340 (not in use)
        ether 02:a0:98:0d:d1:a9 (Enabled virtual interface)

 

 

 

cat /mnt/fas04/etc/rc
hostname fas04
vif create lacp lvif1 -b ip e0a e0b e4a
vif create lacp lvif2 -b ip e4b e4c e4d
vif create single svif lvif1 lvif2
vlan create svif 340 348 351
ifconfig svif-340 `hostname`-svif-340 netmask 255.255.255.0 partner svif-340
ifconfig svif-348 `hostname`-svif-348 netmask 255.255.255.128 partner svif-348
ifconfig svif-351 `hostname`-svif-351 netmask 255.255.255.128 partner svif-351
ifconfig e0M `hostname`-e0M flowcontrol full netmask 255.255.255.0 partner e0M
route add default 10.13.240.1 1
route add net 10.13.244/24 10.13.244.1 1
routed on
options dns.enable off
options nis.enable off
savecore

 

fas04> ifconfig svif-340
svif-340: flags=148043<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500
        inet 10.13.240.24 netmask 0xffffff00 broadcast 10.13.240.255
        partner svif-340 (not in use)
        ether 02:a0:98:0d:d1:d1 (Disabled virtual interface)

  • Re: Enabled/Disabled virtual interface?
    bmccullough
    Currently Being Moderated

    Ok the sub-vitrual interface is not correct, getting closer...

     

    fas04> vif status lvif2
    default: transmit 'IP Load balancing', VIF Type 'multi_mode', fail 'log'

    lvif2: 0 links, transmit 'IP Load balancing', VIF Type 'lacp' fail 'default'
            VIF Status     Addr_set

    (         VIF Status     Up      Addr_set             <-----      funtional entry would be )

            trunked: svif
            lag_inactive:

    (        up:                                                    <----- funtional entry would be )

            e4b: state lag_inactive, since 17Nov2009 01:50:29 (6+19:21:34)
                    mediatype: auto-1000t-fd-up
                    flags: lacp enabled
                    input packets 0, input bytes 0
                    input lacp packets 0, output lacp packets 588654
                    output packets 588653, output bytes 72992972
                    up indications 1, broken indications 0
                    drops (if) 0, drops (link) 0
                    indication: lag_inactive at 17Nov2009 01:50:29
                            consecutive 0, transitions 1
            e4c: state lag_inactive, since 17Nov2009 01:50:29 (6+19:21:34)
                    mediatype: auto-1000t-fd-up
                    flags: lacp enabled
                    input packets 0, input bytes 0
                    input lacp packets 0, output lacp packets 588654
                    output packets 588653, output bytes 72992972
                    up indications 1, broken indications 0
                    drops (if) 0, drops (link) 0
                    indication: lag_inactive at 17Nov2009 01:50:29
                            consecutive 0, transitions 1
            e4d: state lag_inactive, since 17Nov2009 01:50:29 (6+19:21:34)
                    mediatype: auto-1000t-fd-up
                    flags: lacp enabled
                    input packets 0, input bytes 0
                    input lacp packets 0, output lacp packets 588654
                    output packets 588653, output bytes 72992972
                    up indications 1, broken indications 0
                    drops (if) 0, drops (link) 0
                    indication: lag_inactive at 17Nov2009 01:50:29
                            consecutive 0, transitions 1

    • Re: Enabled/Disabled virtual interface?
      bmccullough
      Currently Being Moderated

      Fixed.  The issue was with the network settings on the cisco switches they FAS was plugged into.

       

      Was:

      interface GigabitEthernet1/25                                          
      channel-protocol lacp                                                 
      channel-group 4 mode active                                           
      !                                                                      
      interface GigabitEthernet1/26                                          
      channel-protocol lacp                                                 
      channel-group 4 mode active                                           
      !                                                                      
      interface GigabitEthernet1/27                                          
      channel-protocol lacp                                                 
      channel-group 4 mode active                                           
      !                                              

       

      should of been;

      interface GigabitEthernet1/25                                           
      switchport trunk encapsulation dot1q                                  
      switchport trunk allowed vlan 340,344,348,351                         
      switchport mode trunk                                                 
      channel-protocol lacp                                                 
      channel-group 4 mode active                                           
      !                                                                      
      interface GigabitEthernet1/26                                          
      switchport trunk encapsulation dot1q                                  
      switchport trunk allowed vlan 340,344,348,351                         
      switchport mode trunk                                                 
      channel-protocol lacp                                                 
      channel-group 4 mode active                                           
      !                                                                      
      interface GigabitEthernet1/27                                          
      switchport trunk encapsulation dot1q                                  
      switchport trunk allowed vlan 340,344,348,351                         
      switchport mode trunk                                                 
      channel-protocol lacp                                                 
      channel-group 4 mode active                                           
      !

More Like This

  • Retrieving data ...