2 Replies Latest reply: Dec 10, 2013 4:42 AM by JSHACHER11 RSS

foreach - snapmirror update

JSHACHER11
Currently Being Moderated

Hi guys,

 

I need a script to update snapmirror for a bunch of relationships

 

I created a text file with all the destinations

 

would this work:

 

$dstvols = (Get-Content c:\dstvols.txt)

   

Foreach($dstvol in $dstvols) {Invoke-NaSnapmirrorUpdate -Destination $dstvol}

 

cheers

 

Joel

  • Re: foreach - snapmirror update
    vinith
    Currently Being Moderated

    Hello,  This should work, all destination volumes should belong to the same controller.

    • Re: foreach - snapmirror update
      JSHACHER11
      Currently Being Moderated

      thank you!

       

      it worked fine for almost all the volumes

       

      for one volume I am getting this:

       

      Invoke-NaSnapmirrorUpdate : Source not set on command line or in /etc/snapmirror.conf file.

       

      At C:\Users\smupdate.ps1:10 char:56

       

      + Foreach($dstvol in $dstvols) {Invoke-NaSnapmirrorUpdate <<<<  -Destination $dstvol}

       

          + CategoryInfo          : InvalidOperation: (5.5.5.5:NaController) [Invoke-NaSnapmirrorUpdate], ESNAPMIRRORPA

       

         RSERERROR

       

          + FullyQualifiedErrorId : ApiException,DataONTAP.PowerShell.SDK.Cmdlets.Snapmirror.InvokeNaSnapmirrorUpdate

       

       

       

       

      PS C:\Users> Invoke-NaSnapmirrorUpdate -Destination vol5 -Verbose

       

      VERBOSE: Start SnapMirror update to vol5.

       

       

       

      Source                               Destination                          Status         State                LagTimeTS

       

      ------                               -----------                          ------         -----                ---------

       

      filer1:vol5                          filer2:vol5                          transferring   snapmirrored          00:01:54

       

       

      PS C:\Users\>

       

      I know for a fact that the /etc/snapmirror.conf is fine

      I've also tried from Putty and it works fine

More Like This

  • Retrieving data ...