5 Replies Latest reply: Nov 21, 2013 8:12 AM by nthakur RSS

Wait Command Issue

kofchur
Currently Being Moderated

Hi all,

 

I have a workflow that creates a snapmirror relationship and then has a wait command to verify its status.  Problem is, it throws a false error, saying that the VSM initialization failed, but when I get on the cluster it in fact does initialize.  I'm running WFA 2.0. 

 

Looking at the logs and the code, it looks like it is failing here:

 

 

17:34:23.705 INFO [Wait CM VSM Initialization] Get-NaCredentials -Host 10.4.113.31

17:34:23.705 INFO [Wait CM VSM Initialization] Credentials successfully provided for '10.4.113.31'

17:34:23.720 INFO [Wait CM VSM Initialization] Connect-NcController (with credentials) -Name 10.4.113.31

17:34:25.405 INFO [Wait CM VSM Initialization] Connected to cluster node

17:34:26.497 ERROR [Wait CM VSM Initialization] Failed to initialize VSM relationship between bbcs1va3.mhint://vscifs/cifs_todd_cifs_test_wfa_source and bbcs1sv2.blackboard.com://vsbbcs1va3sm/cifs_todd_cifs_test_wfa_dest

17:34:26.513 INFO [Wait CM VSM Initialization] Cannot find VSM relationship. Failing command

17:34:26.638 ERROR [Wait CM VSM Initialization] Wait Command failed for Workflow 'BB_Create_SnapMirror' with error : Failed to initialize VSM relationship between bbcs1va3.mhint://vscifs/cifs_todd_cifs_test_wfa_source and bbcs1sv2.blackboard.com://vsbbcs1va3sm/cifs_todd_cifs_test_wfa_dest

17:34:26.638 INFO [Wait CM VSM Initialization] ***** Workflow Execution Failed *****

 

# Get the latest job which initializes the vsm relationship

$job = Get-NcJob -Query $query | where {$_.JobDescription -eq "snapmirror initialize of destination " + $DestinationCluster + "://" + $DestinationVserver + "/" + $DestinationVolume } | Sort-Object -Descending -Property JobId | Select-Object -First 1

 

if(!$job)

{

   # No job was found, it could be that the job was purged or that no job was created

   # because the vsm relationship is already in 'snapmirrored' state.

   # Checking that the vsm relationship is in 'snapmirrored' state

   $vsm = Get-NcSnapmirror -SourceCluster $SourceCluster -DestinationCluster $DestinationCluster -SourceVserver $SourceVserver -DestinationVserver $DestinationVserver -SourceVolume $SourceVolume -DestinationVolume $DestinationVolume -ErrorAction SilentlyContinue

  

   if(!$vsm)

   {

        Get-WFALogger -Info -message $("Cannot find VSM relationship. Failing command")

        Set-WfaCommandProgress -Total 1 -Current 0 -ProgressPercentage 100 -Note $job.JobProgress

        throw "Failed to initialize VSM relationship between " + $SourceCluster + "://"+ $SourceVserver + "/"+ $SourceVolume + " and " + $DestinationCluster + "://"+ $DestinationVserver + "/"+ $DestinationVolume

   }

   else

   {

 

Thanks in advanced!

 

-todd

 

More Like This

  • Retrieving data ...