5 Replies Latest reply: Nov 8, 2013 6:02 AM by kukacz123 RSS

Problem with Global Config on SnapCreator 4.0p1

Francesco Duranti
Currently Being Moderated

Hi, I've a question on Global configuration. I'm migrating our old 3.5 environment one configuration at a time and I've a little problem with something related to global configuration.

I have a global.config in the root config folder with some globally defined parameters and then I've local global.conf configuration  under the profile folders to change options and define locally needed parameters.

Now I have a backup/snapshot done on some vfilers that is not working because I've in the root global.conf  the options:

 

NTAP_CONSISTENCY_GROUP_TIMEOUT=RELAXED

NTAP_CONSISTENCY_GROUP_WAFL_SYNC=Y

NTAP_CONSISTENCY_GROUP_SNAPSHOT=Y

 

I've put the same options with N in the local profile global.conf:

NTAP_CONSISTENCY_GROUP_SNAPSHOT=N

NTAP_CONSISTENCY_GROUP_WAFL_SYNC=N

 

but when I run the backup I get the error that consistency group are not supported on vfiler (but I've disabled it on the local global.conf).

I've tried to put the same option on the itromfsv02.conf file but it seems that the snapconfig continue to get the root global configuration ones.

Is this normal?

How are option loaded/used?

 

If I do the reverse (define "N" in the root global.conf and "Y" in the global.conf or itromfsv02.conf configuration file) it seems to work correctly (and report the error).

 

 

This is the error (just to document it as it's not the error that is important but the problem on how the options seems to load from local/global configuration files).

 

########## Starting Consistency Group Snapshot copy for all controllers ##########

[Wed Oct 2 17:43:40 2013] INFO: Starting Consistency Group Snapshot copy for vfiler_ITROMFSV02

[Wed Oct  2 17:43:44 2013] INFO: STORAGE-02001: Creating consistency group Snapshot copy [BCK-hourly_20131002174339] on volumes [[p_home, n_home, v_home, vfroot_ITROMFSV02]].

[Wed Oct  2 17:43:44 2013] ERROR: com.netapp.snapcreator.storage.executor.ZapiExecutorException: netapp.manage.NaAPIFailedException: API not supported. (errno=13012)

    at com.netapp.snapcreator.storage.executor.ZapiExecutorImpl.run(ZapiExecutorImpl.java:62)

    at com.netapp.snapcreator.storage.api.ontap.Ontap7ModeApi.consistencyGroupSnapshotStart(Ontap7ModeApi.java:1400)

    at com.netapp.snapcreator.storage.StorageCoreImpl.consistencyGroupStartSnapshot(StorageCoreImpl.java:115)

    at com.netapp.snapcreator.workflow.task.CGSnapshotTask.execute(CGSnapshotTask.java:70)

    at com.netapp.snapcreator.workflow.impl.SCTaskCallable.call(SCTaskCallable.java:48)

    at com.netapp.snapcreator.workflow.impl.SCTaskCallable.call(SCTaskCallable.java:20)

    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)

    at java.util.concurrent.FutureTask.run(FutureTask.java:138)

    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)

    at java.lang.Thread.run(Thread.java:662)

Caused by: netapp.manage.NaAPIFailedException: API not supported. (errno=13012)

    at netapp.manage.NaServer.invokeElem(NaServer.java:671)

    at com.netapp.snapcreator.storage.executor.ZapiExecutorImpl.run(ZapiExecutorImpl.java:53)

    ... 10 more

 

[Wed Oct  2 17:43:44 2013] ERROR: STORAGE-02003: Creating consistency group Snapshot copy [BCK-hourly_20131002174339] on volumes [[p_home, n_home, v_home, vfroot_ITROMFSV02]] failed with error [netapp.manage.NaAPIFailedException: API not supported. (errno=13012)];

[Wed Oct 2 17:43:40 2013] ERROR: Consistency Group Snapshot copy for vfiler_ITROMFSV02 volumes[p_home, n_home, v_home, vfroot_ITROMFSV02] failed exiting !

[Wed Oct  2 17:43:44 2013] ERROR: Task: cgsnapshot with config:FS_Share@itromfsv02 failed

  • Re: Problem with Global Config on SnapCreator 4.0p1
    Siva Ramanathan
    Currently Being Moderated

    Hello Francesco,

     

    config file >> Profile Global >> Super Global

     

    Profile Global overrides Super Global

    config file overrides Profile Global

     

    Anything in your config file is final

    If you want a key value to be supplied by the profile or super gloabl file, put them only in the appropriate place and don't mention anything in the config file.

     

    The values are controlled by USE_GLOBAL_CONFIG in the config file.

    What is the value of USE_GLOBAL_CONFIG in your itromfsv02.conf?

     

    As a easy test you may try with these.

    USE_GLOBAL_CONFIG=N

    NTAP_CONSISTENCY_GROUP_SNAPSHOT=N

    NTAP_CONSISTENCY_GROUP_WAFL_SYNC=N

More Like This

  • Retrieving data ...