7 Replies Latest reply: May 14, 2013 1:03 AM by graemeharney RSS

DataOntap 8.2rc1 and Snapdrive support

graemeharney
Currently Being Moderated

Currently there are no versions of snapdrive for windows listed in the compatbility matrix for 8.2 C-mode

I know there was a beta run, and an curious to what they used, or how long it is going to be before there is a version that is supported

 

any information would be greatly appriciated

  • Re: DataOntap 8.2rc1 and Snapdrive support
    rubinsed1
    Currently Being Moderated

    I was given a tentative answer from NetApp Technical Support that the release schedule for Snapdrive doesn't match up with DataONTAP and that snapdrive won't work until the new releases come out. I am also seeing other issues related to erronous "NFS not licensed, X not exported" which sound very bad (but then the export is still available).

    I'm having an issue where I upgraded a test system to 8.2RC1, and now SMSQL is reporting the following error when attempting to view snapshot copies "Error: Failed to get the list of licenses on the storage system 'x'. Error code: 13007. Error description: This API is no longer supported. USe license-v2-list-info instead."

  • Re: DataOntap 8.2rc1 and Snapdrive support
    rubinsed1
    Currently Being Moderated

    Snapdrive 6.x is not supported and will NOT work with Data ONTAP 8.2.x. We will have to wait for the next version to be released (possibly later in the summer).

    I.E. Don't upgrade to 8.2 until then. It will break all SnapManager products.

    • Re: DataOntap 8.2rc1 and Snapdrive support
      graemeharney
      Currently Being Moderated

      Hi Rubinsed,

      I know 8.2 has changed licenses and potentially the problem is the new license codes thats are tied to a serial number are not recognised by the older software. Question is if we use server based licenses for Snapdrive + products whether or not it works (will let you know as we will be testing it shortly as the Netapp won't give us an answer)

       

      Still confused about the 8.2 beta...didn't they have a single Windows host in the Beta?

      Other problems I currently have

      Don't support Windows (including server 2012) on 8.2 (Snap Drive)

      Don't support Exchange 2010sp3 or 2013 on Server 2012 (SMEX + SnapDrive)

       

      These products have been release and available for some time. It appears netapp have just dropped the ball big time.

       

      Have been told beta programs are coming (again real sketchy on dates) but are Netapp going to potentially be in the position tha Ontap 8.2 is GA and all of the supporting products are either not released or in some form of Beta ?

      • Re: DataOntap 8.2rc1 and Snapdrive support
        rubinsed1
        Currently Being Moderated

        Quoting from the release notes:

        ---

        Specific versions of graphical management interfaces are compatible with certain versions of Data ONTAP. For example, if you want to use OnCommand System Manager with Data ONTAP 8.2, you need to install OnCommand System Manager version 2.2. Earlier versions of OnCommand System Manager and other graphical management interfaces will not work with Data ONTAP 8.2. Visit the Software Download page to learn more about the supported versions and availability of graphical management tools, such as OnCommand System Manager, SnapDrive and SnapManager products, Virtual Storage Console, and more.

        ---

        When Snapdrive 6.5 or older tries to talk to the controller to determine license status, the communication fails because the license API doesn't support 8.2. For this reason Snap Manager products will NOT work. Wait until a newer version of Snapdrive is released that supports 8.2 to test 8.2

         

        Also, OnCommand Core, VSC, Snapdrive, System Manager, and SnapManager must all be upgraded to versions that support 8.2 BEFORE attempting to upgrade to 8.2. Otherwise, you will have to do a downgrade (revert_to) of ONTAP which is disruptive.

         

        FYI, SnapDrive 6.5 fully supports server 2012, together with iSCSI host utilities 6.0.2 for Windows. Make sure you're using that version.

        I dont think the ONTAP version cares what guest OS version you are using provided the tools (such as SnapDrive) support it.

         

        -Ed

        • Re: DataOntap 8.2rc1 and Snapdrive support
          graemeharney
          Currently Being Moderated

          For software that is reliant on talking to the controller to obtain the license keys, I agree, it won't work at all. For products such as snap drive, which can be licensed per server and won't check the controller for the license key, I suspect will work.

           

          I know snapsrive 6.5 works with 2012(but not with 8.2) my problem is snap manager for exchange does not (for exchange 2010 or 2013).

           

          I've known about the 8.2 release for over 18 months, (well before 8.1 was released) and the functionality it brings (snapvault replacement in particular). It is disapointing that with something predicted so far out is missing so many of its supporting products.

           

          This is a move from 7-mode to cluster mode for us, and right now i'm pretty disapointed with the lack of software support netapp.

  • DataOntap 8.2rc1 and Snapdrive support
    graemeharney
    Currently Being Moderated

    Tech have confirmed snapdrive 6.5 server based licenses are working with 8.2. Was then told certain API's won't work. When asked which ones, Netapp still refuse to share the information.

More Like This

  • Retrieving data ...