22 Replies Latest reply: May 23, 2013 7:01 AM by dburkland RSS

First LDAP connection failed then works...

jmalghem2009
Currently Being Moderated

Hello,

 

I have a strange problem with all my 5 WFA servers connected to Active Directory for authentication.

When a user try to log on for the first time since the browser was open, the authentication failed with the message : "The username or password is incorrect"

If the user retry one more time, the authentication works fine.

 

I have the same problem on different servers connected to different domains. All are Windows 2008 R2.

 

THe logon failure generates the following message on the server.log (nothing on wfa_ldap.log) :

2013-04-08 17:45:29,603 BST ERROR [org.jboss.web.tomcat.security.JBossWebRealm] (http-0.0.0.0-80-4) Error during authenticate

java.lang.IllegalStateException: Security Context has not been set

at org.jboss.web.tomcat.security.SecurityAssociationActions$SetPrincipalInfoAction.run(SecurityAssociationActions.java:70)

at java.security.AccessController.doPrivileged(Native Method)

at org.jboss.web.tomcat.security.SecurityAssociationActions.setPrincipalInfo(SecurityAssociationActions.java:270)

at org.jboss.web.tomcat.security.JBossWebRealm.authenticate(JBossWebRealm.java:388)

at org.apache.catalina.authenticator.FormAuthenticator.authenticate(FormAuthenticator.java:258)

at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:417)

at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)

at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)

at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)

at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)

at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)

at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:383)

at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)

at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)

at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)

at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)

at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)

at java.lang.Thread.run(Thread.java:722)

 

Any help will be appreciated.

 

Thanks,

Julien

More Like This

  • Retrieving data ...