11 Replies Latest reply: Dec 17, 2013 3:04 AM by nicholas4704 RSS

Отваливается NFS подключение к VMware ESXi

ZIMINDYNMCS Novice
Currently Being Moderated

Имеется NetApp FAS2240-2 с двумя контроллерами, NetApp Release 8.1.1 7-Mode.

Настроено подключение к хосту VMware ESXi 5.1, сервер видит датастор, создает на нем файлы виртуальной машины, виртуалка какое-то время работает.

Было замечено что попытка скопировать файл на этот датастор с помощью vSphere Client вылетает с ошибкой по таймауту. Также через неопределенное время ESXi перестает показывать содержимое папок на датасторе, т.е. датастор отображается в статусе normal, список папок на нем виден, а при входе в папку видим надпись "Searching datastore..." и все.

ESXi управляется сервером vCenter 5.1, на него установлен VSC 4.1. Консоль видит подключенные контроллер, но описывает его как -unknown-

На втором контроллере создали LUN iSCSI, подключенный к подобному же тому. VSC сразу же правильно определила контроллер, версию ПО, поддерживаемые протоколы. в статусе выдала сообщение: "SSL is not configured".

Датастор, подключенный по iSCSI, работает без нареканий.

Подскажите, как победить NFS, в чем может быть проблема?

  • Re: Отваливается NFS подключение к VMware ESXi
    GERA.SUKHOV Kart Racer
    Currently Being Moderated

    По моему опыту - в сетевом соединении с томом NFS.

    1. Попробуйте установить VSC v.4.1 и с помощю его установить рекомендуемые параметры на хосте.

    2. Выделите отдельный сетевой интерфейс на хосте для доступа к датастору (чтобы по нему не проходила миграция машин).

    3. Убедитесь что нигде затыков не возникает (промежуточные коммутаторы).

    • Re: Отваливается NFS подключение к VMware ESXi
      ZIMINDYNMCS Novice
      Currently Being Moderated

      VSC установлен, он видит контроллер, но не может определить его параметры, показывает как "неизвестный".

      Сетевой интерфейс выделенный.

      Все подключено к одному коммутатору, перегрузок на интерфейсах нет, полка пока в режиме пусконаладки, так что трафик минимальный.

      • Re: Отваливается NFS подключение к VMware ESXi
        GERA.SUKHOV Kart Racer
        Currently Being Moderated

        Извините, но из Вашего ответа не понятно, были ли применены параметры для ESX хоста из VSC.

        Выделенный интерфейс где? На СХД или ESX хосте?

        У меня был похожий случай в похожей конфигурации. Обсуждалось в "VMware & NetApp с nfs v.3". Точной причины установить не удалось, но есть сильное предположение, что сетевой интерфейс ESX хоста был перегружен миграцией виртуальных машин, которая спорадически возникала и принимала лавинообразный характер. После перехода на FC ситуация не повторялась.

        Так что если сможете выяснить точную причину, то не поленитесь - отпишитесь. Мне будет интересно.

        • Re: Отваливается NFS подключение к VMware ESXi
          ZIMINDYNMCS Novice
          Currently Being Moderated

          Рекомендуемые параметры для ESXi из VSC были применены подключенным хостам.

          Выделен интерфейс как на ESXi ,так и на СХД.

          Пост "VMware & NetApp с nfs v.3" я прочитал, но у меня ситуация все же другая, виртуальные машины не мигрируют между хостами, СХД подключено сейчас только к 2 хостам, и на нем размещена всего одна виртуалка.

  • Re: Отваливается NFS подключение к VMware ESXi
    murzic2000 Sprinter
    Currently Being Moderated

    Хотелось бы посмотреть логи:

    с СХД и с ESXi хоста. Есть ли там записи о проблемах с датастором.

     

    Проверьте MTU на сетевом оборудовании:

    Используете ли вы Jumbo Frames. Если да, настроено ли все верно на свичах и на СХД?

     

    Настроен ли доступ к СХД со стороны консоли VSC?

    VSC видит контроллер как -unknown-, если не настроены права доступа к СХД.

    • Re: Отваливается NFS подключение к VMware ESXi
      ZIMINDYNMCS Novice
      Currently Being Moderated

      в логах на СХД пока ничего криминального не вижу, какой конкретно файл смотреть?

       

      настройка сетевых интерфейсов:

      NetApp FAS2240-2

       

      netapp-head2> rdfile /etc/rc

      hostname netapp-head2

      ifconfig e0a mtusize 9000 flowcontrol send

      ifconfig e0b mtusize 9000 flowcontrol send

      ifconfig e0c mtusize 9000 flowcontrol send

      ifconfig e0d mtusize 9000 flowcontrol send

      ifgrp create multi vif1a -b ip e0a e0c

      ifgrp create multi vif1b -b ip e0b e0d

      ifgrp create single vif1 -b ip vif1a vif1b

      ifconfig vif1 192.168.50.21 netmask 255.255.255.0 mtusize 9000 flowcontrol send

      ifconfig e0M `hostname`-e0M mtusize 1500

      route add default 192.168.11.1 1

      routed on

      options dns.enable off

      options nis.enable off

      savecore

      netapp-head2>

         

      Cisco 2960

       

      interface Port-channel2

      switchport access vlan 50

      switchport mode access

      switchport nonegotiate

      flowcontrol receive on

      !

      interface GigabitEthernet0/19

      switchport access vlan 50

      switchport mode access

      switchport nonegotiate

      flowcontrol receive on

      channel-group 2 mode on

      !

      interface GigabitEthernet0/20

      switchport access vlan 50

      switchport mode access

      switchport nonegotiate

      flowcontrol receive on

      channel-group 2 mode on

      !

      interface Vlan50

      ip address 192.168.50.202 255.255.255.0

      !

       

      #show system mtu     

       

      System MTU size is 1500 bytes

      System Jumbo MTU size is 9000 bytes

      System Alternate MTU size is 1500 bytes

      Routing MTU size is 1500 bytes

       

      Доступ к СХД к консоли удалось настроить, когда перевели один из контроллеров на iSCSI LUN - тогда VSC увидел контроллер как netapp (права доступа настроены)

      • Re: Отваливается NFS подключение к VMware ESXi
        murzic2000 Sprinter
        Currently Being Moderated

        1. Я имел ввиду файлы /etc/messages

        2. На Cisco нужно сделать MTU больше 9000, так как кадр выходящий из NetApp еще требует обрамления.

            Я бы поставил размер 9216 байт

         

        3. И еще. Можно мне схему подключения? На NetApp у вас 4 порта, а на Cisco только 2. Куда ведут остальные?

  • Re: Отваливается NFS подключение к VMware ESXi
    nicholas4704 CertifiedPlus Sprinter
    Currently Being Moderated

    Добрый

     

    Похоже на проблему с Jumbo Frames

    Переключите на ESX и Netapp интерфейсы в MTU 1500, посмотрите результаты.

     

    Nick

  • Re: Отваливается NFS подключение к VMware ESXi
    DARK_ANGEL Novice
    Currently Being Moderated

    1. Проверьте  что все хосты  esxi пользующиеся датастором имеют одинаковую версию.

    2. Проверьте настройку Жамбофреймов  на всем пути от датастора до сервера желательно на хостах и нетапе MTU9000, на  сетевом MTU9216 (если  поддерживает) UPD 2960 вроди  не поддерживает MTU больше 9000. очень похоже на косяк в жамбо.

    3. Проверьте агрегацию каналов если она есть, везде ли работают корректно Езерченелы и ЛАСПЫ.

    4. Проверьте Мультипассинг и политики  распределения нагрузки на сетевых картах Никтиминга.

  • Re: Отваливается NFS подключение к VMware ESXi
    GERMAN.MARKOV Novice
    Currently Being Moderated

    посмотрите пожалуйста, нет ли разницы в значениях: options nfs.tcp.  я видел проблемы когда значения  nfs.tcp.recvwindowsize были разные на ESX и NetApp. Отваливались датасторы и корраптились виртуалки.

    и jumbo frames проверьте как в предыдущем посте предлагают.  плюс если есть юниксовая машина - замонтируйте на неё и потестите.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points