5 Replies Latest reply: Feb 18, 2013 6:12 AM by kevin.moser RSS

Not able to access CIFS Share on 8.1.2 Cluster Mode

kevin.moser CertifiedPlus Novice
Currently Being Moderated

Im trying to access CIFS Shares on my 8.1.2 C-Mode simulator. I used putty and System Manager 2.1 to configure.

Following worked fine:

- created 2-node Cluster

- created vserver with CIFS

- created data LIF with IP which is ping-able

- created CIFS server and joined successfull in AD

- created NTFS Style Volume

- mounted the Volume in Namespace

- created CIFS share with everyone fullcontrol

 

after several searching i found this KB: https://kb.netapp.com/support/index?page=content&id=3012797&actp=search&viewlocale=en_US&searchid=1360918009502

It sayes i have to manualy create a default usermapping win-unix that i can access a CIFS Share.  So i tried but still not working:

kmoscluster::> vserver cifs options modify -vserver kmosvserver -default-unix-user pcuser

kmoscluster::> vserver name-mapping create -vserver kmosvserver -direction win-unix -position 1 -pattern "*" -replacement pcuser

Error: command failed: The pattern * already exists --> why does this allready exist? so i tried this:

kmoscluster::> vserver name-mapping create -vserver kmosvserver -direction win-unix -position 1 -pattern "**" -replacement pcuser

kmoscluster::> vserver services unix-user create pcuser -id 65534 -primary-gid 65534

kmoscluster::> vserver services unix-group create pcuser -id 65534

 

kmoscluster::> vserver show -fields ns-switch

vserver     ns-switch

----------- ---------

kmoscluster -

kmoscluster-01

            -

kmoscluster-02

            -

kmosvserver file

4 entries were displayed.

 

kmoscluster::vserver cifs options> show

 

Vserver: kmosvserver

 

   Default Unix User: pcuser

    Read Grants Exec: disabled

        WINS Servers: -

 

kmoscluster::vserver cifs options> vserver name-mapping show

Vserver        Direction Position

-------------- --------- --------

kmosvserver    win-unix  1        Pattern: **

                              Replacement: pcuser

 

Now when i try to access a cifs share I can see the shares on my win7 but cant open it. (asks me for username&pw but cant authenticate)

what am i doing wrong? I think there is a problem with the usermapping win-unix but no im lost...

 

with 7-Mode setting up a CIFS server was soooo easy, im a bit disappointed right now...

  • Re: Not able to access CIFS Share on 8.1.2 Cluster Mode
    bloehlein Sprinter
    Currently Being Moderated

    Hi Kevin,

     

    since you're mapping your AD-User to a Unix user with id of 65534 chances are small that the volume permissions are right.

     

    Try changing the permissions: volume modify -vserver <Vserver> -volume <Volume> -unix-permissions 777

     

    After that you should be able to get into the share.

     

    Best regards,

     

    Bernd

  • Re: Not able to access CIFS Share on 8.1.2 Cluster Mode
    ismopuuronen Certified Sprinter
    Currently Being Moderated

    Hi,

     

    If the volume is ntfs and you are accessing cifs share from windows host, you don't need to create any user mapping rules.

    Default unix user and group is needed tough, and this is enough. Your vserver name service switch and name mapping switch should be "file" in this case (i think).
    >vserver show -vserver <vserver-name>

     

    Check the allowed protocols from the vserver and from the lif.

    is ntp service running in your vserver?

    If you  are using default export policy and rule it should be fine, but to be sure use you can use example >volume show -vserver <vserver-name> -volume <vol-name> to check the junction path of the volume (other useful info from the volume is also in this output), and then >rule show command to make sure rules are ok for the cifs volume and all the volumes "above" it in junction path.


    Br.
    Ismo.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points