3 Replies Latest reply: Feb 13, 2013 1:08 PM by DRAGONCOW2 RSS

ACP, e0a, and OnCommand System Manager

DRAGONCOW2 Novice
Currently Being Moderated

Hello,

 

    I have one of those filers which do not have an e0p port. I decided to use the e0a port for ACP. I have it wired up correctly and configured it manually via the CLI. The status looks good, and all lights are green. Now, I've set up OnCommmand System Manager and it's yelling at me that the e0a interface parameters are set (dynamically, courtesy of ACP), and those parameters are not to be found in /etc/rc (of course). I'd like to get this "warning"/"network misconfiguration" message to go away. My thought was to set up the interface statically in /etc/rc, but I couldn't find any documentation about whether this would work or not. I see documentation which clearly states you should keep it dynamic and let ACP figure it out..and this would be fine, if only System Manager didn't yell at me. So...either I should be able to statically set the IPs/etc in /etc/rc for the ACP (e0a) interface, or I should be able to tell OnCommand System Manager that e0a is my ACP interface and to leave me alone.

 

    Anyone have any experience with this? I would think this is quite a common "problem", but I see nothing indicating others have run into this.

 

Thanks in advance,

 

    -- Nicholas

 

Notes: OnCommand System Manager is specifically complaining that:

1. IP/netmask is set on e0a, but that config is not found in /etc/rc

2. Flow control is set to full on e0a, but that config is not found in /etc/rc

3. Media type is set to auto-100tx-fd-up, but that config is not found in /etc/rc

 

OnCommand System Manager Version: 2.1

  • Re: ACP, e0a, and OnCommand System Manager
    basisinfra Novice
    Currently Being Moderated

    Hi,

     

    Have the same kind of issue here.

    Systemmanager started complaining after an upgrade to system manager 2.1

    acpadmin configure doesn't add an entry to /etc/hosts nor /etc/rc, so i think system manager should not report an error.

    i am having contact with NetApp about this but it, and explained the whole situation.

    Now they are telling me that i should add an entry in /etc/hosts and /etc/rc while i think that's not what has to be done.

    Still think it is a bug in system manager 2.1

     

    regards Kees

  • Re: ACP, e0a, and OnCommand System Manager
    tflammger Novice
    Currently Being Moderated

    I have the same problem. Was just looking around for information on it.

     

    Config advisor also warns about it, so it's obviously an oversight. It seems like the tools need to refrence the ACP configuration when they're checking the rc integrity.

     

    configadvisor.png

    • Re: ACP, e0a, and OnCommand System Manager
      DRAGONCOW2 Novice
      Currently Being Moderated

      I agree, it looks like the tools are not referencing ACP configurations as one would expect. I do not quite feel comfortable with setting it manually as I believe I read in a NetApp document that you should let ACP figure it out. I'll just ignore these horrible looking errors and hope the next OnCommand System Manager update takes into account ACP configurations when validating the /etc/rc file.

       

      Thanks for the confirmation, everyone.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points