2 Replies Latest reply: Jan 21, 2013 1:54 AM by kunalm RSS

ZExplore with API version 1.19

eladgotfrid1 Novice
Currently Being Moderated

Have a filer with ONTAP version 8.1.2

When connecting with ZExplore to it I get this error:

 

"API Version: Ontapi 1.19 7-mode not listed.

Please select the API document manually."

 

I have downloaded netapp-manageability-sdk-5.0R1 but I dont see this version in the doc folder there only:

C:\netapp-manageability-sdk-5.0R1\doc\ontapi>dir

Volume in drive C has no label.

Volume Serial Number is 8618-23AE

 

 

Directory of C:\netapp-manageability-sdk-5.0R1\doc\ontapi

 

1/20/2013  04:50 PM    <DIR>          ontapi_1.0

01/20/2013  04:50 PM    <DIR>          ontapi_1.1

01/20/2013  04:50 PM    <DIR>          ontapi_1.11

01/20/2013  04:50 PM    <DIR>          ontapi_1.12

01/20/2013  04:50 PM    <DIR>          ontapi_1.13

01/20/2013  04:50 PM    <DIR>          ontapi_1.14

01/20/2013  04:50 PM    <DIR>          ontapi_1.15

01/20/2013  04:50 PM    <DIR>          ontapi_1.17

01/20/2013  04:50 PM    <DIR>          ontapi_1.2

01/20/2013  04:50 PM    <DIR>          ontapi_1.3

01/20/2013  04:50 PM    <DIR>          ontapi_1.4

01/20/2013  04:50 PM    <DIR>          ontapi_1.5

01/20/2013  04:50 PM    <DIR>          ontapi_1.6

01/20/2013  04:50 PM    <DIR>          ontapi_1.8

01/20/2013  04:50 PM    <DIR>          ontapi_1.9

 

What is this version? where can I get it? How can I check the version og the ontap api on the filer directly?

 

Thanks

  • Re: ZExplore with API version 1.19
    sens NetApp Employee Cyclist
    Currently Being Moderated

    Hi,

     

    You are getting this warning because ONTAP 8.1.2 was released after ZExplore (ZEDI) was updated. In other words, ONTAP 8.1.2 api documentation is not included in ZEDI.

     

    In most cases, you can ignore this warning because ZEDI automatically loads the ONTAPI version with the closest match. e.g. since ZEDI did not find Ontapi 1.19 7-Mode, it must have automatically loaded Ontapi 1.15 7-Mode.

    Unless you are looking for some APIs which are newly added in ONTAP 8.1.2 or using some APIs which have undergone some change in ONTAP 8.1.2, you will be just fine using Ontapi 1.15 7-Mode by virtue of the backward-compatibility of ONTAP APIs.

     

    This or a compatible version of ontapi is planned/expected to be included in upcoming release of NMSDK containing the updated ZEDI.

     

    To check the ontapi version on the filer/storage system, use "system-get-ontapi-version" api (under "system" category).

  • Re: ZExplore with API version 1.19
    kunalm NetApp Employee Cyclist
    Currently Being Moderated

    You can download the ZEDI API doc for Data ONTAP 8.1.1 from the link below -

     

    https://communities.netapp.com/community/interfaces_and_tools/developer/zedi

     

    There is no new API added in 8.1.2 compared with 8.1.1, so you can use the same document with 1.17 ONTAPI version.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points