2 Replies Latest reply: Jan 22, 2013 10:55 AM by ASHVITECH RSS

VSC - clone on existing vFiler datastore

ASHVITECH
Currently Being Moderated

We have VSC 4.x plugin installed on the vSphere. We had the netapp and vfiler datastores already created before VSC installation. Now with a plug-in, we are able to clone the VM to any Netapp datastores, but not to vFiler datastore.

 

If I check the box "select vFiler context" and choose vFiler in rapid cloning wizard, it gives the warning on datastore selection page that "there are no existing mapped datastores found on the selected store. You must create a datastore on the previous panel to continue..".   I don't want to create a datastore here, but create clones on existing vfiler datastore.

 

Any help is appreciated.

 

- Attached my vfiler discovery and monitoring details.

- VFiler parent storage connector is already added and vFiler controller is using the same credential.

  • Re: VSC - clone on existing vFiler datastore
    brianjm
    Currently Being Moderated

    In order to use an existing datastore, there are some requirements. I will assume that the datastore is found on a controller that is known to Provisioning and Cloning (since you can select the vfiler context).  I'll also assume that the datastore is healthy and accessible.

     

    Additionally, the datastore must be mounted to every destination host(s). 

    The destination is chosen in the 3rd step of the cloning wizard (Clone Destination).

     

    Also, I noticed from the screen capture that the volume is OFFLINE with a status of 'unknown'.  I would have expected to see a status of 'normal' and a the % capacity where it says OFFLINE.

     

    Let me know what you find when checking the status of the volume.

    • Re: VSC - clone on existing vFiler datastore
      ASHVITECH
      Currently Being Moderated

      Thanks for reply, Brianjm.

       

      - Yes, the multi-store vfiler is found in the discovery of existing netapp system and I am able to select vFiler context in clone wizard.

      - In my case,  the mutlistore vfiler unit "vfiler1" is using the credential of hosting storage systems i,e "netapp2".

      - the datastores are mounted on all esx hosts as per clone destination.

      - The vfiler status on the "Monitoring and Host configuration Overview" tab is normal. Please find the attached screens. Yes, the "Storage Destails -NAS" page displays the storage status "Unknown" I was thinking it is because it is using hosting system.

       

      Can you please guide, what can be the reason the "unknown" status.? I did update and discovery few time, but the status never changed. I cannot understandwhat is wrong here. I am able to clone with VMware clone on this datastore.

       

      Please find the attached screens.

More Like This

  • Retrieving data ...