2 Replies Latest reply: Dec 7, 2012 8:18 AM by peluso RSS

mbralign with nfs copyoffload: "--sparse" option not working, all aligned vmdk's are thick

itcambridge
Currently Being Moderated

We are in the middle of a VMDK alignment project after P2V'ing a lot of legacy W2K and W2K3 physical servers. I've been using mbralign 5.2.1 on an ESX 4.1 server with all datastores mounted via NFS from a NetApp 3240.

 

I was very interested in the NFS CopyOffLoad capabilities of the mbralign tool and got it working for the most part, however the nfs copyoffload feature seems to ignore the "--sparse" command line option. Is this normal operation or broken?

 

If I skip the copyoffload option and just go right to the NFS datastore and manually run mbralign with the --sparse option, it works as I'd expect it to, however this is a much slower process without the copyoffload feature.

 

Is there anyway to engage the nfs copyoffload feature and keep the vmdk files thin with the "--sparse" option?

More Like This

  • Retrieving data ...