7 Replies Latest reply: Jan 4, 2013 6:10 AM by 3GISSMORACLE RSS

Cannot start/stop SMO 3.1

3GISSMORACLE Sprinter
Currently Being Moderated

Hi ,

I've already installed SMO veriosn 3.1 into Hp-UX(11.31 (Itanium) but I've got the error when trying to stop/start the server .

smo_server status

[ERROR] SMO-01104: Error invoking command: SMO-01123: SnapManager server on "host_abc/10.10.10.50" port 27216 is not version 3.1.  Please ensure version 3.1 is running on "host_abc/10.10.10.50" port 27216.

 

Can you please give me some advices ?

 

Best regards

Tien

  • Re: Cannot start/stop SMO 3.1
    thomas.glodde Kart Racer
    Currently Being Moderated

    what does a "smo system verify" say?

    • Re: Cannot start/stop SMO 3.1
      3GISSMORACLE Sprinter
      Currently Being Moderated

      Hi Thomas ,

       

      Here is output of 'verify' command

       

      smo system verify

      SMO-01111: Cannot connect to SnapManager server "https://host_abc:27214/smo_v9/services/SMO".  Please ensure the SnapManager server process is started on the database host "stodb08.networklogon.net/10.170.32.50" on port 27214.  To check the status of the SnapManager server on Windows, use the Windows Services tool.  To check on Unix, use the "smo_server status" command.

       

      Regards

      Tien

      • Re: Cannot start/stop SMO 3.1
        thomas.glodde Kart Racer
        Currently Being Moderated

        Hi Tien,

         

        the service is not running. smo service start gives what error? on linux, there are logfiles in /var/log/smo, im sure hp-ux has logs in a similar directory.

         

        Regards,

        Thomas

        • Re: Cannot start/stop SMO 3.1
          3GISSMORACLE Sprinter
          Currently Being Moderated

          Hi Thomas ,

          It looks like the commando 'smo service start' does not exist

          smo # smo service start

          [ERROR] SMO-01102: Parse error: Unexpected service while processing -verbose|-quiet|credential|clone|profile|operation|version|help|diag|notification|protection-policy|system|repository|backup|cmdfile|plugin

          The command "service" is not valid.

           

          I send to you the output of '/var/log/smo'

          2012-05-31 12:00:55,221 [main] [DEBUG]: SMO-13990: SnapManager for Oracle version 3.1.

          2012-05-31 12:00:55,232 [main] [DEBUG]: SMO-13991: SnapManager for Oracle version 3.1 build 20101001_0156 changeid 1188598 repository version 102 api version 9.

          2012-05-31 12:00:55,233 [main] [DEBUG]: SMO-13992: Java version: 1.5.0.08

          Java vendor: Hewlett-Packard Co. Java home: /opt/NetApp/smo/jre Java classpath: /opt/NetApp/smo/webapp/WEB-INF/lib/smo/smo.jar Java user: root Java dir: /opt/NetApp/smo.

          2012-05-31 12:00:55,273 [main] [DEBUG]: LD_LIBRARY_PATH:

          /opt/NetApp/smo/webapp/WEB-INF/native

          2012-05-31 12:00:55,273 [main] [DEBUG]: ORACLE_HOME:null

          2012-05-31 12:00:55,273 [main] [DEBUG]: ORACLE_SID:null

          2012-05-31 12:00:55,285 [main] [DEBUG]: SMO-13051: Process PID=26602

          2012-05-31 12:00:55,365 [main] [DEBUG]: Checking if SMO Server is running on descriptor file port 27216

          2012-05-31 12:00:55,407 [main] [DEBUG]: keystore is not initialized

          2012-05-31 12:00:55,408 [main] [DEBUG]: Keystore path (original): file:/opt/NetApp/smo/properties/keystore

          2012-05-31 12:00:55,408 [main] [DEBUG]: Keystore path (decoded): /opt/NetApp/smo/properties/keystore

          2012-05-31 12:00:55,473 [main] [DEBUG]: SMO-01305: Command routed to server: host_abc/10.10.10.50

          2012-05-31 12:00:55,484 [main] [DEBUG]: No default effective user was found for host: host_abc' in the credential cache for user: 'root'

          2012-05-31 12:00:55,498 [main] [DEBUG]: SMO-01107: Executing remote command (Method[getServerStatus] on Server[https:/host_abc:27216/smo_v9/services/SMO] by User[root])

          2012-05-31 12:00:59,778 [main] [DEBUG]: Authenticating and authorizing user: 'root@stodb08.networklogon.net'

          2012-05-31 12:00:59,779 [main] [DEBUG]: SMO-01107: Executing remote command (Method[authenticateAndAuthorizeUser] on Server[https://host_abc:27216/smo_v9/services/SMO] by User[root])

          2012-05-31 12:01:00,111 [main] [DEBUG]: SMO-01123: SnapManager server on "host_abc/10.10.10.50" port 27216 is not version 3.1.  Please ensure version 3.1 is running on "stodb08.networklogon.net/10.170.32.50" port 27216.

           

          Regards

          Tien

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points