7 Replies Latest reply: Dec 27, 2012 12:38 PM by joaomarques RSS

VSC 4.0 and Snapmirror

DANTHEMAN
Currently Being Moderated

Running OnTap 8.1, VSC 4.0, ESXi5, vSphere 5 -

 

I created a backup job on a snapmirrored NFS datastore and the snaps are working as expected but the snapmirror is not being initiated by VSC.  I can kick the mirror into action manually but even though I have the check box for snapmirror on the backup job it isn't doing it.  I've read some other posts about having a blank schedule in the snapmirror.conf file which was already there when I checked it.  I use OnCommand to control my CIFS replications/snaps and it works fine but I must be missing something in VSC.  Both the source and destination filers exist in VSC.  I've tried looking at the logfiles generated by VSC but I don't know how to read those tea leaves yet.  For this particular job (first and only), I'm not doing a VMware snapshot - is that required for snapmirror to work?

 

Dan

  • Re: VSC 4.0 and Snapmirror
    sharmas
    Currently Being Moderated

    Hi Dan,

     

    VMware snapshot is not neccessary to initiate a snapmirror transfer. Can you right click the job which has snapmirror update selected, execute it manually and see if it works? If it doesn't can you paste the contents of VSC log file here. You should copy the contents immediately after trying the manual job. Is this happening on only one datastore or all of them? Do you have a snapmirror relationship for the volume backing the datastore established in System Manager?

     

    Regards

    Satinder

    • Re: VSC 4.0 and Snapmirror
      DANTHEMAN
      Currently Being Moderated

      I manuall ran the job in VSC and the same thing happens - I get a new snapshot but snapmirror doesn't kick. 

       

      This is my first go using VSC to initiate SnapMirror.  I wrestled with OnCommand a bit but could never get it to "work" with vCenter.

       

      So, to answer your questions...

      Executing the job manually does not initiate SnapMirror

      The last thing in the VSC log is 4 hours old - there are other log files but I'm not sure which one is the right one.

      I have an existing SnapMirror relationship and can update it via System Manager.

      This is the only datastore that I've attempted to use with VSC.

       

      Is there something on the filer side I should look at to see if I have a permissions problem?  If I understand this correctly the snapmirror is initated on the far side.  I can provision data stores on the far side for my other servers - is there somewhere else in the backup and recovery that I need to do to make sure it is communicating with it?

       

      Dan

      • Re: VSC 4.0 and Snapmirror
        artur.kusiak
        Currently Being Moderated

        When people configure VSC for snapmirror most of the time the target array for the snapmirror gets forgoten to be added to the VSC. VSC requires access to both the source of the backup and the target of the snapmirror transfer. If you look at the SMVI log inside the log directory you will find the error that prevents the snapmirror from starting. If you have added the proper target and source then it might be the credentials for the filer thats the issue.  However you will find the answear in the smvi log.

        Thank you

        Artur

        • Re: VSC 4.0 and Snapmirror
          DANTHEMAN
          Currently Being Moderated

          I think I figured out the problem - not sure how to fix without redoing the replication but the snapmirror was set up directly on the filer and not in the vfiler that actually has the source NFS filesystem.  VSC is nice enough to say:

           

          WARN  - The volume "volprodnfs01data02" does not have SnapMirror set up correctly.

           

          When you go into the vfiler, there is no snapmirror configured.  I'm assuming that I need to redo the snapmirror (not much on it yet) and set it up inside the vfiler and configure the snapmirror.access file?

           

          By the way, the above error is in the server.log file under smvi\server\log\ not the smvi.log that is in the VSC\log directory

           

          Thanks

           

          Dan

  • Re: VSC 4.0 and Snapmirror
    DANTHEMAN
    Currently Being Moderated

    Can anyone verify that the mirror needs to be set up in the vfiler before I go through these motions?  VSC 4.0/Ontap 8.1/vSphere 5.0. 

     

    Dan

More Like This

  • Retrieving data ...