3 Replies Latest reply: Dec 3, 2012 5:13 AM by RENAUD.TOUILLET RSS

Oncommand Host cannot related DataStore to volume/qtree

ludwig.mainguenaud Novice
Currently Being Moderated

Hello everyone,

 

I install OCcore 5.0.1 with OChost 1.1 on Windows 2008R2.

 

I have two ESXi 5.0 with 10Gbit ethernet card to Nexus 5010

 

I have two FAS2240-4 on DOT8.1GA (on for NFS datastore / on for snapvault)

 

No problem to install OCcore all login passwd are good with good test of connectivity.

 

When i install OChost, i create HS, the HS find DataCenter / Vcenter but only one ESXi and when i watch the datastore tab

 

i see that

 

nfs.JPG

 

OCHost is not aware that the NFS datastore are Netapp DataStore. So my VMs isn't related to storage controler, so i cannot backup then

 

I try on Qtree and Volume datastore, same problem.

 

Any Ideas ?

 

BR

  • Re: Oncommand Host cannot related DataStore to volume/qtree
    christin NetApp Employee Sprinter
    Currently Being Moderated

    Hi,

     

    I recommend the following KB article that can help troubleshoot your issue:

    https://kb.netapp.com/support/index?page=content&id=1013241

     

    If the problem persists, please open a case with NetApp Support.

     

    Thanks,

    Christine

  • Re: Oncommand Host cannot related DataStore to volume/qtree
    adaikkap NetApp Employee Grand Marshal
    Currently Being Moderated

    Hi

         I have couple of questions for you.

    1. Can you get the output of the following report for your qtrees or volume that are hosting the vm datastores ?
      • dfm report view nfs-exports <qtree/volume name from dfm>
    2. What is the ontap version of the filers hosting your Datastore ? Is the vm datastores hosted on a vfiler volume/qtreee ?

     

    Regards

    adai

  • Re: Oncommand Host cannot related DataStore to volume/qtree
    RENAUD.TOUILLET Novice
    Currently Being Moderated

    Hi,

     

    I have the same issue with a new deployment. NFS datastores of one of my two filers are not well translated to NetApp volumes. In fact they were ok during a short time but suddently they changed to Non hosted on OnTap... So now protection is not working anymore... (the 4 lasts in the picture)

     

    Datastore.bmp

     

    I re-install the host package and remove/re-add multiple times the Host Service. Nothing changes.

    There's no communication issue between OC core and host when I look to dfm hs diag.

    "dfm report view nfs-exports" give me correct information:

     

    Object ID Type                 Host Name              Export Name                Actual Path                Anonymous User ID No SUID Read-Only Access Read-Write Access Root Access Security

    --------- ------------------------ -------------------------- ------------------------------ ------------------------------ ----------------- ------- ---------------- ----------------- --------------- --------

    153   Active/Active Controller frcqufas01.mycompany.biz /vol/vol0                  /vol/vol0                                  0 True                 rw                            sys
    153   Active/Active Controller frcqufas01.mycompany.biz /vol/cqu_nfs_os/os         /vol/cqu_nfs_os/os                           False                192.168.83.0/24   192.168.83.0/24 sys
    153   Active/Active Controller frcqufas01.mycompany.biz /vol/cqu_nfs_data/data     /vol/cqu_nfs_data/data                       False                192.168.83.0/24   192.168.83.0/24 sys
    153   Active/Active Controller frcqufas01.mycompany.biz /vol/cqu_nfs_pagefile/pagefile /vol/cqu_nfs_pagefile/pagefile               False                192.168.83.0/24   192.168.83.0/24 sys
    154   Active/Active Controller frcqufas02.mycompany.biz /vol/vol0                  /vol/vol0                                  0 True                 rw                            sys
    154   Active/Active Controller frcqufas02.mycompany.biz /vol/vol0/home             /vol/vol0/home                               True                 rw                            sys
    239   Active/Active Controller frmjefas01.mycompany.biz /vol/test                  /vol/test                                    False                192.168.83.0/24   192.168.83.0/24 sys
    239   Active/Active Controller frmjefas01.mycompany.biz /vol/vol0                  /vol/vol0                                  0 True                 rw                            sys
    239   Active/Active Controller frmjefas01.mycompany.biz /vol/mje_nfs_os/os         /vol/mje_nfs_os/os                           False                192.168.83.0/24   192.168.83.0/24 sys
    239   Active/Active Controller frmjefas01.mycompany.biz /vol/mje_nfs_data/data     /vol/mje_nfs_data/data                       False                192.168.83.0/24   192.168.83.0/24 sys
    239   Active/Active Controller frmjefas01.mycompany.biz /vol/mje_nfs_pagefile/pagefile /vol/mje_nfs_pagefile/pagefile               False                192.168.83.0/24   192.168.83.0/24 sys
    240   Active/Active Controller frmjefas02.mycompany.biz /vol/vol0                  /vol/vol0                                  0 True                 rw                            sys
    240   Active/Active Controller frmjefas02.mycompany.biz /vol/vol0/home             /vol/vol0/home                               True                 rw                            sys

     

    Any idea how to force the maping or what could cause the translation issue?

     

    I'am using Ontap 8.1.2 on both filers and OC 5.1 with Host package 1.2.

     

    Many thanks.

     

    Renaud

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points