15 Replies Latest reply: Nov 11, 2012 7:36 PM by avazquez73 RSS

VSC 2.01 - problems with backup...

dormelchen
Currently Being Moderated

hello,

 

i installed the vsc 2.01.

 

The Overview Page is fine - 2 netapp filer and our 3 ESX Hosts - everything "green"

Storage details NAS - i can see the 6 NFS datastores. status "normal"

 

when i look to the backup

"Setup" - i cann see all virtual machines - on SFR

But when i want to create a new backup Job

-> Virtual Entities - i didnt get any option. No Datastores etc.

nothing - so i cannot create an Backup Job.

 

Any idea ?

 

(FAS 2020 -  7.3.5.1    -     Virtual Center Server 4.01 - ESX Server  4 )

 

Thank you

  • VSC 2.01 - problems with backup...
    dormelchen
    Currently Being Moderated

    when i create a job i get:

     

     

    Job failed: Did not find any of the following Datastores or virtual machines to backup: []. Storage system(s) may need to be added.

     

    • VSC 2.01 - problems with backup...
      keitha
      Currently Being Moderated

      In the backup and recovery section of the VSC, under "Setup" did you add in your storage controllers and credentials? You need to add them here seperatly from the other portions of the plugin.

       

      Keith

      • VSC 2.01 - problems with backup...
        dormelchen
        Currently Being Moderated

        yes thats ok.

        i forgot to write that

        • VSC 2.01 - problems with backup...
          keitha
          Currently Being Moderated

          Based on that error message either the Storage controllers did not add correctly to the SMVI portion of the plugin ( you should remove the controllers and re add them) or some communication with vCenter is not right. You do have VMs in those DCs right?

          • VSC 2.01 - problems with backup...
            dormelchen
            Currently Being Moderated

            i tried to remove and readd the filers in th VSC, but that doesnt work.

            "This storage controller still has LUNs and/or NFS exports mapped to the ESX hosts being managed by this vCenter "

             

            And i have VMs in every datastore.... Live machines.. production

            • VSC 2.01 - problems with backup...
              dormelchen
              Currently Being Moderated

              Example Error Message when i try to backup a virtual machine, which runs fine on datastore DS02:

               

               

              Failed to find NFS export path /vol/datastore2 for datastore DS02 on storage system XX.XX.XX.XX . NFS datastores must be exported from a Data ONTAP storage system.
              Unable to manage datastore DS02: Failed to find NFS export path /vol/datastore2 for datastore DS02 on storage system XX.XX.XX.XX. NFS datastores must be exported from a Data ONTAP storage system.

               

               

              but i see these datastores in the overview from the VSC. And our datastores are mounted via NFS to our ESX and they work fine..

              • VSC 2.01 - problems with backup...
                keitha
                Currently Being Moderated

                Oh, I didn't mean for you to remove the datastores from the ESX servers!! Just from the VSC. I think you should open a ticket with NetApp support so that they can guide you via webex.

                 

                (I meant for you to add the NetApp controllers (not the datastores!) from the SMVI -> setup screen which is different from the general vCenter screen)

                 

                Try this.

                 

                1. Go to the "home" screen in vCenter

                2. Click on the NetApp plugin which takes you into the VSC

                3. On the left side you will see 3 sections, click on the "Backup and Recovery" section

                4. Once in Backup and recovery, again on the left select "Setup"

                5. In here click on "Add controllers"

                6. Add you NetApp systems here.

                 

                Keith

              • Re: VSC 2.01 - problems with backup...
                noc@inoc.net
                Currently Being Moderated

                Was there ever any fix for this problem?  I'm getting the same exact issue on VSC + ESX 5.0.0, VCenter5.  NetApp2240 OnTAP8.1.  All NFS exports, everything green, visible and usable in vCenter/ESX.  Whenever I try a VM or Datastore backup I get similar messages:

                 

                2012-03-28 00:43:25,284 [backup:c69db4b131c01bad5d0f2530d0ef2ad7:] INFO  - No storage system configured with interface "172.19.x.x" (172.19.x.x)

                2012-03-28 00:43:25,284 [backup:c69db4b131c01bad5d0f2530d0ef2ad7:] DEBUG - Failed to find NFS export path /vol/vmdata0 for datastore fas0_vmdata0 on storage system 172.19.x.x. NFS datastores must be exported from a Data ONTAP storage system.

                2012-03-28 00:43:25,284 [backup:c69db4b131c01bad5d0f2530d0ef2ad7:] INFO  - Unable to manage datastore datastore-151: Failed to find NFS export path /vol/vmdata0 for datastore fas0_vmdata0 on storage system 172.19.x.x. NFS datastores must be exported from a Data ONTAP storage system.

                com.netapp.smvi.task.vmware.util.InvalidDatastoreException: Failed to find NFS export path /vol/vmdata0 for datastore fas0_vmdata0 on storage system 172.19.x.x. NFS datastores must be exported from a Data ONTAP storage system.

                 

                 

                Yet the ESX hosts and vCenter have all these NFS mounts as active datastores with running VM's.

  • Re: VSC 2.01 - problems with backup...
    bsti@plex.com
    Currently Being Moderated

    I have a very similar issue.  I'm almost 100% sure the issue is I have two volumes with the same name.  They are on separate storage systems, so it's legal, but VCS appears to be getting confused.  I noticed this entry in the log file:

     

    2012-01-13 19:00:07,731 [backup:997072497839aa6396e2acc8825af7cc:] WARN  - Unable to manage datastore vmware_vol1: Unable to discover lun xx:xx:xx:xx:xx:xx:xx:xx@6 mapped to initiator xx:xx:xx:xx:xx:xx:xx:xx used by datastore vmware_vol1 (4f10764f-346b670d-deaf-002481802e04)

    com.netapp.smvi.task.vmware.util.InvalidDatastoreException: Unable to discover lun xx:xx:xx:xx:xx:xx:xx:xx@6 mapped to initiator xx:xx:xx:xx:xx:xx:xx:xx used by datastore vmware_vol1 (4f10764f-346b670d-deaf-002481802e04)

     

    2012-01-13 19:00:08,121 [backup:997072497839aa6396e2acc8825af7cc:] ERROR - FLOW-11008: Operation failed: Did not find any of the following datastores or virtual machines to backup: []. Storage system(s) may need to be added.

     

    The initiator specified is mapped to the storage controller NOT involved in the backup.  I chose a VM target to back up (not a data store).  I'm guessing there is something wrong with the discovery process where VSC tries to determine what to back up based on what VMs you choose.

     

    I verified this was the issue by renaming one of my volumes to something slightly different.

     

    Hope this helps someone down the road.

More Like This

  • Retrieving data ...