Currently Being Moderated

Perfstat (password less) - Scripts

Posted by neto in Databases on Sep 4, 2013 2:44:33 PM

Hi All,


This is neto from Brazil


How are you?


When you are using perfstat even with --sshprivatekey-file it always ask to press Enter on the passphrase for SSH key.


How to fix it: (remember that you need to create perfstat user and public key on NetApp)


Linux and Mac


echo -ne '\n' | ./perfstat8 -t 6 --sshprivatekey-file=/Users/neto/.ssh/id_rsa --verbose --mode=cluster-mode --diag-passwd=cpoc1302


Nossa Senhora:perfstat neto$ echo -ne '\n' | ./perfstat8 -t 6 --sshprivatekey-file=/Users/neto/.ssh/id_rsa --verbose --mode=cluster-mode --diag-passwd=netapp


[09-04-2013 15:38:15]  INFO *------------- perfstat v8.1 (20130314_1964919) -------------*

[09-04-2013 15:38:15]  INFO Parsing CLI options.

[09-04-2013 15:38:15]  INFO Loading preset information from default preset

[09-04-2013 15:38:15]  INFO Total commands are : 526

[09-04-2013 15:38:15]  INFO Total PRESTATS commands are : 383

[09-04-2013 15:38:15]  INFO Total POSTSTATS commands are : 92

[09-04-2013 15:38:15]  INFO Total PARALLEL commands are : 51

[09-04-2013 15:38:15]  INFO Total PARALLEL_PRESTATS commands are : 0

[09-04-2013 15:38:15]  INFO Total PARALLEL_POSTSTATS commands are : 0

[09-04-2013 15:38:15]  INFO Requesting SSH passphrase from user.

[09-04-2013 15:38:15]  INPUT Enter passphrase for SSH key:

[09-04-2013 15:38:15]  INFO Please wait! trying to authenticate using SSH Key pairs.




Create a VBS file and add:


'VBScript Example

Dim oShell

Set oShell = WScript.CreateObject("WScript.Shell")

oShell.Run "c:\users\neto\desktop\perfstat\perfstat8 -t 6 --sshprivatekey-file=c:\users\neto\desktop\perfstat\id_rsa --verbose --mode=cluster-mode --diag-passwd=netapp"

oShell.AppActivate "C:\Users\neto\Desktop\perfstat\perfstat8.exe"

WScript.Sleep 300

oShell.SendKeys "{ENTER}"


Probably you will need to adjust your path on the windows script


All the best



NetApp - I love this company!


Filter Blog

By date:
By tag: